Заметка Какие возникли сложности

SOUL

АдминкА
Администратор
Сообщения
7.298
Симпатии
10.553
Баллы
266
#1
Для своего тестового форума я выбрала бесплатный хостинг

Пожалуйста, Войдите или Зарегистрируйтесь для просмотра скрытого текста.


Он довольно шустрый для халявного хостинга, но мне пришлось столкнуться с рядом сложностей.
Но обо всём по-порядку.

После

Пожалуйста, Войдите или Зарегистрируйтесь для просмотра скрытого текста.

, при переходе по
Код:
http://адрес_моего_сайта/переименованный_admin.php
вместо того, чтобы попасть в админку, у меня выходила ошибка.

Имя файла admin.php я меняла через ftp и в library/XenForo/Link.php вносила изменения там же, то есть изменения по

Пожалуйста, Войдите или Зарегистрируйтесь для просмотра скрытого текста.

я делала через ftp.

Я подумала, что что-то упустила, перепроверила несколько раз, но своей ошибки не нашла. Потом я зашла в панель управления хостингом => файловый менеджер и увидела, что изменения, о к-х я написала выше, якобы не были сделаны.

Тогда я непосредственно в файловом менеджере изменила имя файла admin.php и внесла изменения в library/XenForo/Link.php. И всё заработало! - админка стала открываться по нужному адресу.

Еще у меня была проблема с некорректным отображением аватарок по умолчанию после загрузки и установки нового стиля.
Они выглядели так 123.jpg

Видимо, из-за супер-пупер крутого файлового менеджера хостера beget моя загрузка стиля через ftp тоже совершалась некорректно. И после того, как я загрузила этот стиль с помощью файлового менеджера, проблема с авками решилась!
 

SOUL

АдминкА
Администратор
Сообщения
7.298
Симпатии
10.553
Баллы
266
#2
Совсем забыла написать о проблеме, возникающей при установки дополнений после переименования admin.php по этому мануалу 54 — копия.jpg .

Хотя я об этом точно писала здесь! - походу, это последствия переезда с beget'а, исчезли некоторые сообщения Girl_Sad38

Придется писать заново...

Так вот, чтобы дополнения, русификаторы и пр. благополучно устанавливались после переименования файла admin.php, я, когда возникала ошибка, вместо admin.php 59.jpg прописывала новоеимяadmin.php, нажимала Enter, и всё устанавливалось.

НО, буквально вчера я узнала, что, чтобы не было таких заморочек при установке дополнений и пр., нужно еще внести изменения в файле

library/XenForo/ViewRenderer/HtmlAdmin.php

Найти
Код:
$this->_response->setRedirect('Admin.php?tools/run-deferred&redirect=' . urlencode($redirectTarget), 303);
также изменить на своё.
 

hiroyuki

Проверенный
Сообщения
36
Симпатии
18
Баллы
3
#6
Skaiman, ну когда обновимся тогда делать не буду:cool:
 
Вверх Снизу